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LIGHTCONVERSE TOOLS Interface Overview  

  

 

 

 

 

 

 

Truss – Truss Library of different truss manufacturers    

Scaffold – Scaffold Library 

Objects – Object Library (equipment, musical instruments, etc.) 

Fixtures – Lighting Equipment Library (compatible with LIGHTCONVERSE)  

3D Models – Library of basic elements/templates 
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Tool Manager 
 

Tool Manager allows you to group elements to groups, select the necessary elements, show 

or hide them in the 3D space and lock selected elements. 

The Tool Manager contains two tabs: Group and Properties     
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selected element 
Group name (number 

of elements in a group) 

Element block 

Show/Hide an 

object 
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Mouse  
Mouse Control Operation: 

The Compass is the area located in the lower right corner of the screen and is used to 

navigate within the 3D space. 

  

When moving within the 3D space, you can quickly navigate using the mouse buttons. Place 

your mouse cursor in the Compass area, then press and hold the Left Mouse Button to rotate 

the view on the horizontal pane and zoom the camera in and out. Use your Mouse Scroll 

Wheel to rotate the view on the vertical pane. See diagram below. 

Mouse Buttons Description 

 

 

 

 

 

 

 

NOTE: To move the camera left/right and up/down, use the arrow keys on your keyboard. 

3D Space Area 
 

In the 3D space area, positive directions are shown for the X, Y and Z axes in red, green 

and blue, respectively. X, Y and Z directional icons in red, green and blue, respectively, will 

also appear when an element is selected.  

The origin of X, Y, Z coordinates (Origin point) in the 3D space area is set in a default 

location. By selecting a 3D model and choosing “Set Origin To Object” from the Selection 

Menu, the origin of the coordinates will be changed and the coordinate axes center will 

become the center of the selected model. To reset the coordinate’s origin back to default, 

choose Reset Origin from the Selection Menu. 

 

  

Left Mouse Button 

Rotate view on horizontal pane  

Zoom camera in/out 

 

Scroll Wheel 

Rotate view on 

vertical pane  

 Right Mouse 

Button  

Set camera 

position to default 

 

Extra Mouse Button  

Move camera relative 

to cursor 
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Modes 
 

There are two main modes when working with LIGHTCONVERSE TOOLS:  

1. Constructor Mode – unlimited number of items can be used. 

The default Constructor workspace is loaded when LIGHTCONVERSE TOOLS is 

first started.  

 

2. Warehouse Mode - limited number of items available. 

To switch to the Warehouse Mode, select Set Warehouse from the Menu toolbar. A dialog 

box will appear with information about all the elements used in the project. After closing it, a 

“Select missing items” message will be displayed.   

To work in Warehouse Mode properly you need to pre-fill the Warehouse with relevant 

information about the construction items and equipment to be used in your project. 

To switch to the filling Warehouse mode, select Edit Warehouse from the Mode Menu.  

When in Warehouse mode, Warehouse/ will be displayed in the information field. 

 

 

 

 

To switch to Constructor Mode, select Set Library from the Mode Menu. When in Constructor 

Mode, Library/ will be displayed in the information field 

You can build your project in Constructor Mode and switch into the Warehouse as needed, 

information about missing project items will be displayed in the additional tab. All missing 

items will be highlighted, which makes it possible to move them to their particular group. 
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Balance Calculator in Warehouse Mode 
 

LIGHTCONVERSE TOOLS software provides an elements balance calculator tool which 

shows an inventory of any missing elements for a certain time period. It is necessary to fill 

the warehouse to use this tool. Note that it is possible to create multiple warehouses, for 

example, for a warehouse which has different divisions or for other companies involved. For 

this purpose, there are import and export functions of the current base of elements.    

 

 

 

  

 

 

 

 

 

 

 

 

Balance Calculator Window 
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Workspace 
 

Layers Setup 

Your own images (*.jpeg or *.png representations of plans, schemes, drafts, etc.) can be 

imported as layers in the project by selecting Import from the File Menu. To change the 

image size by enlarging or reducing its scale, select the Properties Tab in the Tool Manager 

and press the Size button. An Image Size pop-up will appear and you will see actual size of 

the image. To zoom in, place your cursor at the intersection point of the coordinate grids 

(the origin). This point will be the center of picture scaling.  

The size can be changed by the following key combination: Ctrl + Mouse Wheel. For more 

precise adjustment, use Ctrl + Shift + Mouse Wheel. After the image setup is complete, it 

is advisable to lock it (to prevent from slipping) by pressing the  Lock Object Button in Tool 

Manager. 

 

It is also possible to scale the image on the vertical Z axis via the same procedure. 
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Truss Construction 
 

Press Truss on the Palette bar to select a truss manufacturer. A sample TRUSS category is 

also available.  

Next, select the desired truss type followed by the manufacturer’s truss series, truss element 

form category (Straight, Corner, Circle, Accessory, Structure) and truss item from the 

expanding menu.  

 

 

 

 

 

 

NOTE: Many common truss constructions can be found pre-built in the Structure form 

category. 

 

When an element is selected, information about it will appear 

in the lower left area of the screen. 

When adding additional elements, pressing Enter will locate the 

object to the highlighted (flashing red) area. 

When selecting similar traverse elements, the Snapping tool allows you to quickly place an 

element without extra adjustment, as the system defines the proximate installation options 

automatically.  

NOTE: When using the Snapping tool, if you select a group of element the last element will 

be the linking one. The last element has the 3D Manipulator. 

Types of 

elements 

Manufacturers  

 

Truss types 

Truss series 

List of items 

Last numbers define 

the truss length  
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The 3D Manipulator appears after selecting each element or groups of 

elements and helps you to transform different elements such as move, 

rotate and scale (similar operations can be performed in Tool Manager). 

While inserting Corner truss elements, it is possible to spin traverse by 

pressing W and change snapping elements, by pressing Q.  

 

 

Show truss point 

Snapping points are illuminated with backlit orange dots. To disable/enable illuminated 

snapping points, select Show Truss Points in the View Menu. 

NOTE: If your computer is not powerful enough, you may want to disable illuminated 

snapping points. 

Align Angle 

For the orthogonal alignment of the elements use Selection> Align Angle from the Menu bar. 

Flip 

You can watch the mirror reflection of elements by pressing Selection> Flip coordinates X, 

Y, Z the Menu bar.  In this case, the reflection point is the center of the traverse group. Left 

and right elements take the correct position as well. 

Align selection to floor 

To quickly set an element to a zero horizontal position, use the keyboard combination  

Ctrl + F. 

 

 

 

 

 

 

 

 

Pressing Q – 

Selected 

element rotates 

around the 

snapping point 

 

Pressing W – 

Selected element 

changes the 

snapping point 
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Scaffold Construction 
  

 

Press the Scaffold library on the Palette bar to select a scaffold object.  

Scaffold construction can be performed using the Snapping tool. If there is a problem with 

snapping an object it means that it is impossible to snap in that location. 

It’s possible to rotate scaffold Ledgers, Diagonals, Double Ledgers around Vertical and 

Accessory elements by pressing Q.  

 

The 3D Manipulator takes the position of the tilt angle of the element while installing 

Diagonals so you can move the element as needed. 

If you need to move the element strictly along the orthogonal axes, hold down the Shift 

button for the 3D Manipulator to operate along the X, Y, Z axes. 

  

Whenever you need to 

change the direction of 

the 3D Manipulator, 

press Shift key.  
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Use of 3D Objects, 3D Models 
 

There is a wide range of 3D Objects and 3D Models included in LIGHTCONVERSE TOOLS 

that can be added to a project, including elements such as sound systems, human models, 

primitive figures, decorations and more. It is also possible to import external models which 

use *.obj and *.x (DirectX) formats by selecting Import from the File Menu. During the import 

process, a dialog box will appear allowing you to set the scale.   

 

When importing models with textures, the textures will be imported automatically. In case of 

texture absence, a dialog box will appear with a list of the missing associated textures.   

When selecting 3D Objects and 3D Models, additional possibilities appear in the feature 

manager: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Name and type of the selected 

model 

Model motion along the X,Y,Z 

coordinates 

 

Element rotation on the X,Y.Z 

coordinates 

 
Constructor of building of the arrays 

of models 

 
Color 

change 

 

Mode of reflection of the glares 
Reflection of the 

surfaces inwards 

 

Setting transparency 

Models from 0 to 100% 

Change of size 
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Export project to LIGHTCONVERSE 3D SHOW PLATFORM 
 

In the Main Menu, select "File> Export> Export to LIGHTCONVERSE" to export the 

project. It is possible to export selected items only (Export Selected) or the whole project 

(Export All). The exported file format has a .3dl extension and all structural elements, 3D 

objects and lighting devices are packed and stored in the file. 

Before exporting, it is highly recommended to check the correct location of the World 

Center, as it affects the importation of the project into LIGHTCONVERSE. 

 

Import (* .3dl) into LIGHTCONVERSE 3D SHOW PLATFORM 

 

Project importation into LIGHTCONVERSE is accomplished in two steps: 

Step 1 - Import objects in the Room Editor 

Step 2 - Import lighting devices in the DMX Editor 

 

STEP 1 - Import objects in the Room Editor 

In the Room Editor, before importing, make sure to set the World Center (WORLD 

CENTER) to "FLOOR". Simply select the floor and press WORLD CENTER. It is also 

necessary to set the Room Size required for your project: 

 

 

To import 3D objects of your project, place the cursor on a line in the Object List and press 

the Browse 3D-Model button. Next, press the Explorer button to open Windows Explorer 

and navigate to the location of the .3dl file.  

 

Browse 3D Model 

button 

Place cursor on an 

Object List line  
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STEP 2 - Import lighting devices in the DMX Editor 

In the DMX Editor, place the cursor on a line in the Fixture List and press the Import 

button, located at the top left of the screen. Next, press the Explorer button to open 

Windows Explorer and navigate to the location of the .3dl file.  

 

 

The lighting devices imported are replaced with virtual ones from the LIGHTCONVERSE 

library. 

  

Import lighting 

devices button 

Place cursor on 

a Fixture List line  
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Ruler Mode 
  

 

To switch into Ruler Mode, select Ruler from the Mode Menu. Ruler Mode will appear at the 

top center of the screen and a Rulers tab will open from which you can select what vertices 

type points you want to use a ruler to measure from (Center bound box, Bound box, Snap). 

The parametric ruler binds to selected element points and performs measurement 

calculations when moving the element in Constructor Mode. 

Press ESC button to exit Ruler Mode. 

 
  

Choose ruler top 

points: 

1. Center bound box 

2. Bound box  

3. Snap 

 

Ruler and its length 

Delete Rulers and 

Change Colors 
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DMX Patch Mode  
 

In the DMX Patch Mode users can assign lighting fixtures to specific DMX addresses. Fixture 

DMX addresses can then be shown on the drawing and printed out. Assigned DMX 

addresses are also saved while exporting a project into LIGHTCONVERSE.      

To enter DMX Patch Mode, select “Mode> DMX Patch…” in the Main Menu. A pop-up 

notification “DMX Patch Mode Click here or press Esc to exit” will appear in the center 

of the screen. 

During patching you can select fixtures in the 3D space or in the DMX Patch Window. All 

fixtures have given channels. 

There are two tabs in the DMX Patch Window:  

Table View – a table type view of the DMX address space. 

Universe View – a graphic type view of the DMX address space. 

In Table View, the addressing for the fixtures is assigned in the order in which they are 

selected. Highlighting of fixtures can be single and group. Table View allows to sort by 

headings. 

 

 

Unit Number – a sequence number of the fixture which is set by the program as a fixture is 

inserted into the project. 

User ID – a number for fixture ID use in professional lighting consoles.  

Firm – Manufacturer of lighting fixture.  

Name – Name/type of lighting fixture.  

Universe – DMX universe choice.  

Channel –  Address of fixture.  

Address – Continuous addressing. 
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After selecting a fixture or group of fixtures, press the  Patch  key. The following options will 

appear in the Patch Properties window:  

  

 

 

 

 

 

The fixtures which have been addressed move to the top according to the list with text color 

changed to dark. 

In the Universe View tab, the patching in shown in the graphic view. The fixtures can be 

moved according to the addresses.  
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Printing Options 
 

Construct a custom pdf print-out of your show with annotations, links, information tables, 

equipment lists and more. 

To open the print constructor select “File” > “Report” > “PDF Report” 

NOTE: Saving print outs is carried out in *.LCR format and also in *.PDF. Created or 

changed drawing should always be saved, otherwise all changes will be lost. 

 

Print-out sheet creation 

When selecting Paperwork from the Mode Menu, a “Report Options” dialog box will open. 

 

 

 

After selecting any desired report options, a preview window (Viewport) is downloaded to 

the sheet where its size and location on the sheet can be chosen. If the 2D Icons option is 

selected, Fixture type elements are downloaded and can be edited. Other images can be 

added to the sheet by selecting Load Jpeg from the Edit Menu, if needed.   

Before opening the module of edit and print of the sheet, it is necessary to select the position 

of camera in the 3D space. For setting orthogonal projections, it is necessary to set the 

camera at 0 degrees by pressing Ins (NumPad), to cancel - press Ins (NumPad) again. 

When choosing orthogonal projections in Report Options, selecting the 2D Icons option 

allows for editing of Fixtures. Selecting the 3D Views option allows for inserting an image on 

the sheet in a perspective view. 

Option of turning on the 

render of the preview 

window (Viewport) 

For the render of all 3D 

views  

For the render of the 

projection view (in front, 

on the left, on the right, 

on top, from bottom, 

behind) 

 

For the render in frame 

view (Wireframe) 
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After opening the edit module of the sheet, it’s necessary to configure parameters of the 

sheet.  

 

Sheet format attributes 

To change the sheet format and its orientation, right click on the border of the sheet.   

 

 

The number of the created sheets depends on the set task. To add new sheets to the project, 

choose the  button at the bottom of the project, to delete the sheet choose the  button. 

Choice of sheets is carried out by choosing the appropriate tabs.  

  

Report Options data 

To fill in print out data of the print sheet, select Edit > Report Options ( ). All information 

can be saved for use on other sheets. 

 

Tool palette 

The Tool palette can be used during creation and has the following capabilities: Add Note, 

Add Text, Add Size, Add Patch, Add Table, Add Report Options, Add Fixture. All tools have 

setting and edit features.  
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Open Project 

 
Save Project 
 

 
Save Project As.. 

 
Undo 

 
Redo 

 
Pan 

 Zoom 

 
Zoom All 

 
Load JPEG file 

 
Add Note 

 
Add Text 

 
Add Size 

 
Add Size Arrow 

 Add Size Dot 

 Add Size Slash 

 Add Patch 

 Add Patch without Edging 

 Add Patch with Edging 

 Add Table 

 Add Fixture Key Table 

 Add Trusses Table 

 Add Scaffold Table 

 Add Fixture Table 

 Add Report Options 

 
Add Fixture 

 
Save Sheet(s) to PDF File 

 

 

 

Shortcuts and Commands 

Ctrl + Z –  Undo action Ctrl + X – Redo action 

Ctrl + Y – Redo action 

Ctrl + D – Duplicate selected unit(s) 

Alt + Arrows – Duplicate selected unit(s) in relative direction 

Enter – Locate object to highlighted (flashing) area 

Ctrl + Enter – Copy and locate object to highlighted (flashing) area 
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Q –  Change free connection junctions of selected truss 

W – Rotate the selected elements at connection point of trusses 

  

Mouse Wheel Scrolling Actions: 

 - Use scroll wheel on Compass area – Tilt camera  

 - Use scroll wheel on scene area – Move camera up/down 

 - Use scroll wheel in the library – Scroll through library elements         

 
- Use scroll wheel on selected element axes – Rotate the 
element      

 
- Use scroll wheel + Ctrl in 3D Substrate Size and Image Size – 
Change size of 3D models and images  

 
- Use scroll wheel + Ctrl + Shift in 3D Substrate Size and Image 
Size – Change size of 3D models and images smoothly 

 

Ctrl + A - Select all objects 

Esc 
– Deselect all objects (also exit Ruler mode, 3D Substrate Size 
mode, Warehouse and Image Size mode) 

Delete – Delete all selected objects 

Space – Center camera on selected objects 

Left Arrow – Move camera left 

Right Arrow – Move camera right 

Up Arrow – Move camera up 

Down Arrow – Move camera down 

Home – Move camera forward 

End – Move camera backward 

Shift + Arrow – Slow camera motion 

1-9 – Navigate camera to standard positions 

Insert – Toggle to perspective/orthogonal view 

Left Mouse Click – Single selection 

Ctrl + Left Mouse 
Click 

– Add to multiple selection 

Alt + Left Mouse 
Click 

– Remove from multiple selection 

 

Double Left Mouse 
Click 

– Multiple selection of continuously connected units 

Double Right Mouse 
Click 

– Multiple selection  

Ctrl + Left Mouse 
Click 

– Select main unit from already selected units 

Ctrl + S – Save in file 

Ctrl + Shift + S – Save As to project file 

Ctrl + O – Open a file 

F12 – Toggle visibility of navigator 

Ctrl + R – Reset angles 

Ctrl + F – Align selected unit with the floor 
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Ctrl + Alt + N – Show truss name 

Ctrl + L – Show a library window 

Ctrl + Alt + C – Show truss color 

Ctrl + Alt + M –  Toggle Imperial/Metric measurement system 

Ctrl + Alt + R – Rip apart 

Alt + F4 – Exit  

 

 

Menus of the Main Modes (Constructor Mode, Warehouse 

Mode) 
Mode   

Open Warehouse  

Paperwork… Move to the mode of constructor of print and design of sheets 

Ruler…  

DMX Patch…  

File  

New... Creation of a new .lctools project 

Open... Open the .lctools project 

Open Recent Open the project from the list of the last 10 projects 

Save Save the .lctools project 

Save... Save the .lctools project under another name 

Import >>   

.lctools Import the project into the current project 

.x *.x file import into the project  

.obj *.obj file import into the project 

.jpg *.jpg file import into the project  

.png *.png file import into the project 

Export >>   

Export to 
LIGHTCONVERSE Project export into the .3dl file 

 Export to Project… Export of the selected objects of the project into the .3dl file 

View   

Show Window Library 

Library switcher on trusses in the view of tree (windows style) and switcher of 
all libraries (Truss, Scaffold, Objects, Podiums, Fixtures, 3D Models) in the 
view of tabs (Direct X graphic style)  

Show Group Window Show/Hide a window of groups 

Show Navigator Show/Hide the camera navigator of the 3D world 

Show Truss Names Show/Hide names near the trusses and scaffolding in the 3D world 

Show Truss colors  

Show Truss Points 
Show/Hide points of connections of trusses and scaffolding in the view of 
shining points 

Show Detect Collision 
Show/Hide a flashing red highlighting of the objects when there is a full match 
of the positions in the space according to categories (Truss, Scaffold) 

Show Fixture Unit 
Numbers Show Fixture Unit Numbers 

Show Fixture Addresses Show Fixture Addresses Patching 

Show Floor Grid Show/Hide a grid on the floor 

Floor Grid Size... Edit the grid size on the floor  

Set Imperial/Set Metric Switch of the English and metric coordinate systems 

Paper Switch to the displaying of the 3D view on the white background 
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Camera >>   

Top View from Top 

Back Rear view 

Front Front view 

Left Left side view 

Right Right side view 

Top Front Right Isometric view from top, from front, from the right 

Top Front Left Isometric view from top, from front, from the left 

Top Back Right Isometric view from top, from the back, from the right 

Top Back Left Isometric view from top, from the back, from the left 

Perspective Turn on/Turn off the perspective 

Focus to selection Camera flight to the selected object with an axis 

Reset Camera reset to the initial position 

Rip Apart  

Brightness…  

Edit   

Undo Cancel the last action 

Redo Repeat the cancelled action 

Selection   

Reset Angles Reset all angles of the object turns 

Align Angle Align the smallest angle of the turn to the straight angles 

Align selection to floor Align an object to the floor 

Duplicate Duplicate 

Deselect Remove selection from the selected objects 

Select All Select all objects 

Delete Delete selected objects 

Select Collision Select the objects which are in collision 

Flip >> 
Build a symmetric structure from the selected elements with consideration of 
replacement of the objects on their analogues 

Flip X Local With respect to the minimum X value of the Bound Box of the structure 

Flip Y Local With respect to the minimum Y value of the Bound Box of the structure 

Flip Z Local With respect to the minimum Z value of the Bound Box of the structure 

Flip X Global With respect to the YZ plane 

Flip Y Global With respect to the XZ plane 

Flip Z Global With respect to the XY plane 

Set Origin To Object Set the World Center value in the position of the axis of the selected object 

Reset Origin Reset the World Center value to 0, 0, 0 

Report   

Camera View To Jpeg... Save the camera view into the .jpg file   

Specification... Save a specification into the .txt file   

PDF... 
Save the camera view on the white background with the main stamp (table) 
with information about the project into the .pdf file 

Jpeg with comments... Save the camera view with the text information (comments) into the .jpg file 

Warehouse  

Edit Warehouse…  

Check project for 
Warehouse Inventory 
conformity…  

Balance calculator…  

Help  

About Show the About window with a list of hot keys 
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